Kiến thức quản trị

RMAN Compatibility Matrix

Khi sử dụng RMAN Compatibility Matrix  để backup CSDL, chúng ta cần chú ý đến tính tương thích giữa phiên bản CSDL, phiên bản RMAN đang thực thi, phiên bản của catalog database, catalog schema.

Khi tính tương thích bị vi phạm, chúng ta có thể gặp các thông báo lỗi sau:

RMAN-6186 / RMAN-06186 – associated message: “PL/SQL package %s.%s version %s in %s database is too old”
RMAN-6429 / RMAN-06429 – associated message: “%s database is not compatible with this version of RMAN”.

Dưới đây là thông tin ma trận tương thích:

Target/Auxiliary
Database
RMAN Executable Catalog Database Catalog Schema
8.1.7.4 8.1.7.4 >=8.1.7 < 12C 8.1.7.4
8.1.7.4 8.1.7.4 >=8.1.7 < 12C >=9.0.1.4
9.0.1 9.0.1 >=8.1.7 < 12C >= RMAN executable
9.2.0 >=9.0.1.3 and <= Target database >=8.1.7 < 12C >= RMAN executable
10.1.0 >=9.0.1.3 and <= Target database >=9.0.1 < 12C >= RMAN executable
10.2.0 >=9.0.1.3 and <= target database >=9.0.1 >= RMAN executable
11.1.0 >=9.0.1.3 and <= target database >=10.2.0.3 (note 1) >= RMAN executable
11.2.0 >=9.0.1.3 and <= target database >=10.2.0.3 (note 1) >= RMAN executable
12.1.0.x =12.1.0.x >=10.2.0.3 = RMAN executable

Để được tư vấn kỹ hơn, mời bạn để lại comment bên dưới hoặc click vào Fanpage của chuyên gia:https://www.facebook.com/ora.huytran/

 

Leave a Reply

avatar
  Subscribe  
Notify of

Địa chỉ: Tầng 6, tòa nhà Việt Á, Số 9 Phố Duy Tân, Dịch Vọng Hậu, Cầu Giấy, Hà Nội